MINOR Installer Bug report for APOC test 20 Aug 2019

janusjanus Member, Braver of Worlds
The actual bug forum seems not open yet, so I put it here. Even if it is only a minor thing it might help avoid a bit of frustration.

Installer not finding file during restart

Description
When running the installer, in my case also MS Visual C++ 2017 was installed and the PC restarted. In the automatically restarting of the Ashes installer, the error message "error reading from file" for a roaming app data file appears and install aborts.

Bug Reproduction Steps
I assume restart the computer during installation process. Seems to be a rare/theoretical issue, but everybody who still needs Visual C++ 2017 Redistributable installed will run into this.

Expected Result
Should have just installed APOC.

Bug Report - Actual Result
install-ERROR.png
I checked in the file explorer and the whole "binaries" folder was missing.

Workaround/Solution
Problem solved by restarting the installer. I assume it was only caused by the first attempt's PC restart deleting temporary files.

Comments

  • akabearakabear Member, Pioneer
    Workaround for this in my case was to try to install "as administrator" but like your solution, it may have just been second attempt as apposed to the additional rights that let it get through second time.
  • SoulsOnFireSoulsOnFire Member, Settler
    edited August 20
    After abort I was still able to start APOC.

    Is it possible this has something to do with having installed the previous version?



    I have two folders in 'GAMES'.
    1. APOC
    2. APOC VERSION 2

    - The APOC folder has 'Binaries' and 'Content' with the APOC -Win64-Shipping.

    - APOC VERSION 2 has 'Binaries' but it's empty.

    APOC and Launch_Ashes application are in the GAMES folder and seem to be working.
    Tq3LCNj.png
  • jikapjikap Member, Pioneer
    I ran into this as well, aborting and running the installer a second time worked.
  • janusjanus Member, Braver of Worlds
    now that the APOC bug section is open, maybe a Mod could move the thread over there?
  • Hiya - thanks for reaching out to report this! It does appear to be a mismatch having to do with not removing all of the old files from our previous launcher - that's why we called out specifically in our FAQ to be sure you've removed all your old files!

    I'm going to go ahead and move this on over to the Bug Reporting section, in case anyone runs across this in the future as well :)
Sign In or Register to comment.