Apocalypse download freezes every minute

Hey, I am currently downloading Ashes of Creation: Apocalypse and I am really excited to try it out. I downloaded the installer from the Ashes of Creation website, not from Steam.

The download stops for a minute, then it`s downloading again for like 10 seconds, it stops again for a minute and continues downloading again for some seconds and that goes on and on. What could be the reason for this and is there a way to fix this? I don`t usually need several hours for 6 Gigabyte so I am pretty sure it's not the fault of our bandwith.
Help would be really apreciated :)

Comments

  • CaelronCaelron Member, Braver of Worlds
    Took me about 2 1/2 hours to fully download, with lots of abuse. Mine would always freeze at ~36% and 67% almost every time. If I ever closed it (forcefully OR accidentally) during that time, when I restarted, it would give me an "unreal engine 4" failure and bug report screen every time.

    The only way I got past it was to re-launch the download, which gives you the option to "repair" the game.
    After going through the "repair" option 4 or 5 times, I decided to just delete the "APOC" folder inside the game itself... then tried the "Repair" again... and it worked! Then I didn't have any download problems after.

    Not a clue why it worked for me after threatening to delete it... but maybe give that a try before a full re-download?

    Short version: Close and re-open
    Medium version: Close, launch download again, click "repair", re-launch
    Long version: Delete an internal file folder, launch download again, "repair", re-launch
  • Hi there! If you had previous test builds installed prior to Early Access, we recommend removing all old files first to ensure a cleaner & smoother install process.

    In addition, you may want to try running the launcher as administrator, and/or check that your downloads are not being throttled in some other way.

    I'm going to go ahead and close this thread out now, but please feel free to reach out to our tech support team if this issue persists for you, so we can investigate further: https://support.ashesofcreation.com/hc/en-us/requests/new?ticket_form_id=360000558614
    3ztrsitvhj3s.gif
This discussion has been closed.