Greetings, glorious adventurers! If you're joining in our Alpha One spot testing, please follow the steps here to see all the latest test info on our forums and Discord!

Problem with the ashes of creation shop

Sloth0272Sloth0272 Member, Braver of Worlds, Alpha One
When i log in on the ashes of creation site and go to the shop it is completely empty. All the possible pack upgrades that were there are now gone and every cosmetic currently on sale is also gone. I have tried using different browsers, i have tried edge, google chrome and fire fox. I have tried clearing my cookies. i have tried every way to contact the ashes of creation support team that i can think of. I have tried posing in the discord help channel, i have tried contacting their support through the site, i have tried direct messaging LieutenantToast on discord. Now i am trying on here. I knew that messaging LieutenantToast probably wouldn't get a reply since i am sure she is busy but someone in my guild recommenced that i give it a shot.

Below are screen shots of my store before i log in and after i log in along with my automated reply from customer support going through their site, and the message i sent LieutenantToast.

Is there anyone around that is able to help me out?


  • Sloth0272Sloth0272 Member, Braver of Worlds, Alpha One
    I also made a new account and the store works, but my main account with my summer sale pack has an empty store
  • Hi there friend! It sounds like you've already taken the right steps by reaching out to our support team directly and opening a ticket; we're experiencing a bit of a higher volume than usual right now so queue times are longer than they typically are! We appreciate your patience while our team works on responding to everyone <3

    As I believe I'm already assisting you on Discord with this as well, I'm going to go ahead and close this thread out, but please don't hesitate to reach back out if there's anything else we can help you with in the meantime!
This discussion has been closed.