No support button on website

Hi,

I emailed the support team a while back on [email protected] in regards to a problem.
Today I got an email back saying they are no longer doing support over email, and that I instead have to go to the website and click the "Support crystal" and make a ticket.

But, there is no such support button. I've searched the entire website, I've used the search-function on the website, I've tried Googling "Ashes of creation support", nothing.
I can only find a crystal button for "Shop".

So I have a problem with no way of contacting support and the directions for opening a support ticket tells me to click a button that isn't there.

Am I blind/stupid, how do I get in touch with support? All I need is a re-send of my kickstarter code.

Thanks in advance!

Comments

  • Hi @Gothicca !
    The support button is where I've pointed too in the image!

    If you still can't see the support button let us know :3 

  • You need to hit crtl + mouse wheel scroll to adjust your resolution.
  • I can't see it, it's not there!

    You need to hit crtl + mouse wheel scroll to adjust your resolution.
    I tried that and it still doesn't show up. I've gone from minimum to maximum resolution using that method and I still only get the "Shop" crystal button at the bottom left hand corner. But no "Support" button anywhere.
    This is so weird, I use a normal 1920 x 1080 resolution screen and Google Chrome.

    Can anyone link the direct link instead? I have zero clue why I can't get it to show up
  • Unfortunately there is no direct link as it is a widget built into the page itself. Have you tried opening the site in a different browser such as FireFox or Edge?
  • ArchivedUserArchivedUser Guest
    edited May 2018


    About browsers supported by Web Widget

    The Web Widget is supported on the following browsers as of January 23, 2017.

    On desktop:

    • Google Chrome: latest two versions
    • Microsoft Internet Explorer: Internet Explorer 11 and Edge
      Note: Keep in mind that Internet Explorer 11 is susceptible to memory leaks, which may impact performance.
    • Mozilla Firefox: latest two versions
    • Apple Safari: latest version

    On mobile:

    • iOS Safari: latest two versions
    • Android browser: latest version
    • Chrome Mobile for Android and iOS: latest version
  • Thanks for the help guys.

    I checked I have the newest version of Chrome but it's just not showing up.
    I opened the website with Microsoft Edge instead and it did show up, so the problem solved itself by me using another browser like you suggested.

    Don't know why my Chrome browser is not cooperating but at least it worked on Edge :)

    Thanks again!
  • It can be related to AV settings as a possible etiology.
This discussion has been closed.